CloudInvoice offline

Incident Report for TecAlliance

Resolved

we confirmed the issue is solved and they are processing the invoices now
Posted May 17, 2025 - 13:02 UTC

Update

We are currently continuing to investigate the issue that has been identified. Our technical team is actively analyzing the root cause and working to resolve it as quickly as possible.

We understand the importance of this matter and will provide further updates as soon as more information becomes available. We appreciate your patience and understanding in the meantime.

If you have any specific questions or require further assistance, please feel free to contact our support team.
Posted May 17, 2025 - 11:59 UTC

Update

we are still continuing to investigate this issues
Posted May 17, 2025 - 11:22 UTC

Update

we are continuing to investigate this issues
Posted May 17, 2025 - 10:24 UTC

Investigating

We are currently investigating this issue
Posted May 17, 2025 - 08:53 UTC
This incident affected: e-Invoicing (Other - e-Invoicing).