[TecCom] : Alert Warranty & Returns | UI

Incident Report for TecAlliance

Resolved

This incident has been resolved.
Posted Nov 26, 2023 - 10:21 UTC

Investigating

Customers might realise problems in process or UI
Posted Nov 26, 2023 - 08:40 UTC
This incident affected: Warranty & Returns (new) (UI (User Interface)).